Tag Archives: Cisco

Port Channel between two (Cisco Catalyst) switches

Connecting switches with two or more Ethernet cables is a piece of cake :)
All you need to do is create/configure a port-channel on both switches and plug in the cables.

The following setup should work on Cisco Catalyst switches. Three different VLANs are used:
Access ports for clients (vlan2) and server/admin network (vlan1) and voip (vlan3).

Step 1:
Define port-channel (Switch A)

interface Port-channel2
description ### Uplink-Channel to switch B ###
switchport trunk allowed vlan 1,2,3
switchport mode trunk
switchport nonegotiate

Step 2:
Assign port-channel to physical interfaces (Switch A)

interface GigabitEthernet0/1
description ### Uplink-Channel to switch B ###
switchport trunk allowed vlan 1,2,3
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active

interface GigabitEthernet0/2
description ### Uplink-Channel to switch B ###
switchport trunk allowed vlan 1,2,3
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active

Please note that [id] in “channel-group [id] mode active” must match [id] in “interface Port-channel[id]”

Step 3:
Create a port-channel and assign it to physical interfaces the same way as on Switch A now on Switch B

interface Port-channel2
description ### Uplink-Channel to switch A ###
switchport trunk allowed vlan 1,2,3
switchport mode trunk
switchport nonegotiate

interface GigabitEthernet0/1
description ### Uplink-Channel to switch A ###
switchport trunk allowed vlan 1,2,3
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active

interface GigabitEthernet0/2
description ### Uplink-Channel to switch a ###
switchport trunk allowed vlan 1,2,3
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active

Step 4:
Get yourself two Ethernet cables and plug them in

Basic configuration of Cisco Catalyst switch

Some time ago I was asked to do a basic configuration of a Cisco Catalyst Switch. Apart from applying a correct VLAN configuration I did the following:

  • Configure NTP
  • Create user
  • Set enable password
  • Configure remote logging

Configure NTP

switch1(config)#ntp server 1.1.1.1
switch1(config)#clock timezone CEST +1
switch1(config)#clock summer-time CEST recurring

run “show ntp status” and check for “Clock is synchronized” Please use the correct timezone for your location.

Create User

switch1(config)#username user privilege 15 secret p@ssw0rd
This creates a user (user) with highest privileges and with the password p@ssw0rd

Set enable password

switch1(config)#enable secret abc123
This configures the enable password

Configure remote logging


switch1(config)#logging on
switch1(config)#logging trap debugging
switch1(config)#logging host 1.1.1.1

This configures the remote logging to the syslog server with the IP address 1.1.1.1. Don’t forget to configure the syslog server accordingly. The log-level here is “debugging” which is rather noisy – change it to something different if you like.